lg e900

All posts tagged lg e900

Back in 2011 my dad’s friend gifted me a Windows Phone 7 device: LG Optimus 7 (E900). Not a bad phone, maybe one of the best between WP7 devices.
LG E900 - Optimus 7
It worked well until the day that… ehm, it had a bath in olive oil (please don’t ask me how it happened!).
I immediately removed the battery and wrapped up with some absorbent paper. After I disassembled it and tried to remove all the oil with some isoprophilene, demineralized whater and spirit; I’ve just spent over three days to make it pretty good.
I was lucky, the phone booted up, but of course some problems still remains. In fact the speaker was less loud than before, the display have some spot and… WiFi and Bluetooth not works anymore.
What happened?
Here is where Samsung join us.
Maybe was my fault, because of the oil bath, but the WiFi/Bluetooth chip was in short and the phone goes a bit unstable, overheated and of course the battery life was reduced to one hour… MAX!
To properly charge it I needed the original power adapter (that is about 1Ah), and it took about six hours. Though a PC it was pretty impossible.
But by searching on Google I found something of interesting. In fact this phone seems suffers from a BAD hardware bug that could just appear from a moment to another, without symptoms. The WiFi/Bluetooth chipset fault and the phone never startup again (it stuck on the LG logo). XDA guys have solved in different ways. Someone had cut off the PCB piece where the chip is placed, some other just done a re-heat of the chip at about 380°C.
Unfortunately mine wasn’t just desoldered, but BURNED, and I just decided that to make the phone works back again, in the best way possible I had only to remove that chip.
Ah… just forgotten: the chip in question is made by SAMSUNG!
Honestly I really don’t like Samsung product, because the quality of product is really poor and the support is more poor. (A day I’ll tell you my misadventures with a friend’s Samsung Monitor!). So now, I suspects, also components lacks of quality…

And here how I’ve just fixed the problem:

Of course I’ve disassembled the entire device, and looked for the board where the chip is on.
LG E900 - Optimus 7

After discovered it (the one in the center) I’ve removed tha protection plate and looked at the chip.
As you can see the chip is literally BURNED, and there’s nothing to do, except changing the entire board.
LG E900 - Optimus 7

Then I’ve just grabbed a pair of pliers and powered on the “SMD Rework” on my soldering station, by setting the airflow temperature at about 350°C.
LG E900 - Optimus 7 LG E900 - Optimus 7

Maybe I had to reflow at highter temperature (maybe 400°C), but after some minutes the chip was desoldered and removed. I have to polish the BGA connection from the remaining solder lead.
LG E900 - Optimus 7

And as final result… The phone works again! Of course I’ll never able to use WiFi and Bluetooth again, but SIM card, phone operations, data over 3G works pretty good, and the battery life was restored! Better than nothing! :D

LG E900 - Optimus 7

 

Thanks to Snake, my partner in science, for helping me with my bad english!